Startseite Joomla Very Simple Image Gallery - FAQ & Troubleshooting
Hauptmenü
Meist gelesen
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79
Support

Wenn Sie die Erweiterungen und Scripts auf diesen Seiten nützlich finden, freue ich mich über Ihre Unterstützung. Danke!

Betrag: 

Neueste Beiträge
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109
Very Simple Image Gallery Plugin FAQ & Troubleshooting
Geschrieben von: Andreas Berger   
Sonntag, den 27. September 2009 um 17:48 Uhr

PROBLEM: Leere Seite beim Aufruf eines Artikels mit Galerie

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

PROBLEM: Weder Bilder noch Thumbnails werden angezeigt (leere Rahmen)

PROBLEM: Nur der Code {*vsig}ordner{/vsig*} wird angezeigt - Darstellung in Modul

 

 

PROBLEM: Leere Seite beim Aufruf eines Artikels mit Galerie

Führt der Aufruf einer Seite auf der eine Galerie eingebunden ist dazu, dass nur eine leere Seite angezeigt wird, dann ist der Grund dafür vermutlich ein "Fatal Error", ausgelöst durch die GD lib, eine Erweiterung von PHP. Um den Fehler beim Aufruf der Seite angezeigt zu bekommen reicht es, im Joomla! Backend unter "Site" > "Konfiguration" > "Server" im Abschnitt "Server" den Wert für den Parameter "Fehler berichten" auf "Maximum" zu setzen. (Anmerkung: Im aktivern Betrieb einer Webseite sollte das nach Behebung des Fehlers wieder zurückgesetzt werden!) Ruft man jetzt die Seite mit der Galerie auf, dann wird einem vermutlich ein "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)" angezeigt. Um dessen Behebung kümmert sich der nächste Punkt dieser FAQ.

 

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

Tritt beim Aufruf der Galerie diese Fehlermeldung auf (die angegebenes Bytes variieren), dann bedeutet das, dass die Erzeugung der Bilder/Thumbnails aus den Originalbildern mehr Arbeitsspeicher in Anspruch nimmt, als der Webserver einem PHP Script zur Verfügung stellt.
Man könnte nun entweder (in der lokalen Testumgebung) den Speichergrenzwert hochsetzen oder (am Webserver) den Webhoster darum ersuchen, den Account diesbezüglich besser auszustatten, doch in 99% der Fälle ist die Lösung einfach: Kleinere Bilder!

Das betrifft in erster Linie die Abmessungen (Breite/Höhe) der Bilder und nicht zwingend die Dateigröße. Die GD library von PHP benötigt zum Laden des Bildes in den Arbeitsspeicher (meines Wissens) rund 40 Bit pro pixel. Das bedeutet - zum Beispiel - die Erzeugung des skalierten Bildes bzw. des Thumbnails von einem Originalbild mit 800x600 Pixel benötigt zumindest 800x600x40bit = 2.23 MegaByte an Speicher.
Bei einem Bild 600x450 ergibt die Rechnung 600x450x40bit = 1.29 MegaByte, und so weiter.

Vielfach werden Bilder in Auflösungen hochgeladen, die für die Darstellung auf einer Webseite schlicht überdimensioniert sind. In einem üblichen Joomla! Template verbleiben für die Darstellung einer Galerie im Kontext des Inhalts vielleicht 600 bis allerhöchstens 800 Pixel an Breite. Bilder dieses Formats lassen sich - je nach Bild - bereits mit 50 bis 100 Kilobyte in ausgezeichneter Qualität darstellen. Lädt man Bilder direkt von der Digitalkamera hoch, dann haben diese aber Formate von bis zu 3000 Pixel Breite und sind teilweise bis zu 3 oder 4 Megabyte groß.
Die Nachteile großer (Dateigröße) Bilder liegen auf der Hand: Der Upload dauert wesentlich länger, man braucht mehr Platz am Server und man verschreckt seine Besucher, denn kaum jemand ist gewillt, auf das Laden eines Bildes von 3 MB oder mehr zu warten. Dazu kommt, dass das Skalieren der Bilder mit einem geeigneten Programm (z.B.: GIMP) wesentlich bessere Resultate bringt, als wenn man diese Aufgabe dem Browser überlässt.

Im Optimalfall skaliert man also die Bilder offline und lädt sie in einem Format hoch, das entweder exakt dem Format entspricht, in dem sie dann angezeigt werden (wenn mand das bereits ausprobiert hat) oder ein wenig größer (ein wenig größer deshalb, weil Browser beim hinaufskalieren noch schlechtere Ergebnisse bringen als beim Herunterskalieren).

Ach ja, die Fehlermeldung verschwindet dann übrigens auch.

 

PROBLEM: Weder Bilder noch Thumbnails werden angezeigt (leere Rahmen)

Werden an Stelle der Bilder und Thumbnails nur die Alternativtexte oder leere Rahmen angezeigt, dann überprüfen Sie bitte im Konfigurationspanel des Plugins den Status der GDlib.

Die GD Library, kurz GD oder GDlib, ist eine Programmbibliothek zur dynamischen Erzeugung und Manipulation von Grafiken und eine der verbreitesten Erweiterungen von PHP. Die Very Simple Image Gallery greift auf diese Erweiterung zu, um die skalierten Bilder und Vorschaubilder zu erzeugen.
Um über die Hinweise im Konfigurationspanel des Plugins hinaus zu überprüfen ob und wenn ja in welchem Umfang diese Erweiterung am Server zur Verfügung steht, ruft man im Joomla! Administrationsinterface den Menüpunkt Hilfe > Systeminfo >PHP-Information auf. Auf dieser Seite sucht man nach "gd". Im Optimalfall findet sich ein Abschnitt mit folgendem oder ähnlichem Inhalt:

gd

  • GD Support enabled
  • GD Version bundled (2.0.34 compatible)
  • FreeType Support enabled
  • FreeType Linkage with freetype
  • FreeType Version 2.1.9
  • T1Lib Support enabled
  • GIF Read Support enabled
  • GIF Create Support enabled
  • JPG Support enabled
  • PNG Support enabled
  • WBMP Support enabled
  • XBM Support enabled

Die erste Zeile zeigt an, dass die Erweiterung aktiviert ist, die zweite Zeile gibt Auskunft über die installierte Version. Danach folgen Angaben über zur Verfügung stehende Funktionalitäten und unterstützte Bildformate. Für die Very Simple Image Gallery sind die Formate GIF, JPG und PNG von Bedeutung.
Ist die GDlib nicht aktiviert oder werden diese Bildformate nicht unterstützt, dann sollte man das (in der lokalen Testumgebung) ändern oder (am Webserver) den Webhoster darauf hin ansprechen, ob eine Aktivierung möglich ist. Ohne diese Erweiterung ist die Very Simple Image Gallery nicht einsetzbar.

 

PROBLEM: Nur der Code {*vsig}ordner{/vsig*} wird angezeigt - Darstellung in Modul

Wird im Frontend keine Galerie sondern nur der Aufruf - {*vsig}ordner{/vsig*} (ohne Sterne) - angezeigt, dann überzeugt man sich zuerst, dass das Plugin auch aktiviert ist! Ist das der Fall, dann liegt das Problem in vielen Fällen darin, dass die Galerie nicht im Kontext des Hauptinhaltes angezeigt werden soll, sondern an einer Modulposition.
Nicht alle Erweiterungen, die anbieten eigenen Content an einer Modulposition anzuzeigen unterstützen die volle Funktionalität des Joomla! Frameworks und damit die Funktionen die das Plugin benötigt um fehlerlos zu arbeiten.
Von zumindest zwei Erweiterungen gibt es bislang aber Rückmeldungen von Nutzern, die bestätigen, dass diese Funktionalität bereitgestellt wird.

Eines ist das Modul "Module: Content with Plugins", gelistet bei extensions.joomla.org unter der Rubrik "News Display" > "Articles Embed".
Das Andere ist das Modul "Plugin in Module", gelistet bei extensions.joomla.org unter der Rubrik "Core Enhancements" > "Embed & Include".

Aber auch wenn das Plugin auf diese Art und Weise an einer Modulposition genutzt werden kann, ein Modul ist kein Artikel was dazu führt, dass dem Plugin - das die Identity des Artikels üblicherweise benutzt, um eindeutige Identifizierungen für JavaScript/CSS zu erzeugen - diese Unterscheidungsmöglichkeit fehlt. Solange es auf einer einzelnen Seite nur 1 Galerie gibt ist das kein Problem, aber wer vorhat, auf einer einzelnen Seite mehrere Galerien an Modulpositionen darzustellen, dem würde ich empfehlen auf eine Galerie ausweichen, die explizit als Modul entwickelt wurde.


Für Fragen und Anregungen steht die Kommentarfunktion zur Verfügung. Bitte geben Sie bei Ihrer Frage die verwendete Joomla! Version an und posten Sie bei Problemen - soweit möglich - einen Link zur betroffenen Seite.

Wer für sein Projekt zusätzliche Funktionen oder Adaptierungen über die Möglichkeiten des hier gebotenen Supports benötigt, der ist eingeladen, mich mit einer Beschreibung der gewünschten Leistungen und dem angedachten Budget per Email zu kontaktieren (Menüpunkt "Kontakt" im Topmenü).

Wer die Erweiterung nutzt den bitte ich, sie auf extensions.joomla.org zu bewerten und einen Erfahrungsbericht zu posten.

Zuletzt aktualisiert am Sonntag, den 20. März 2011 um 13:30 Uhr
 
Kommentare (31)
Can no longer copy or edit working pages - we just see the {vsig}folder{/vsig} code
21 Mittwoch, den 30. November 2011 um 12:45 Uhr
Mike

This is a brilliant plug-in and has worked really well for the past 18 months.

However for some reason we can no longer copy or edit a page without the gallery disappearing and just diplaying the code {*vsig}folder{/vsig*}
Here is a page that we copied this morning and renamed www.studiomap.co.uk/index.php?option=com_content&view=article&id=164&Itemid=57
The original page is still showing the gallery as before.
We are happy to upgrade to the Pro version but didn't want to risk upgrading in case we lost our existing galleries. At the moment we have in excess of fifty pages that call images very successfully and we can't afford for them to stop functioning.
We are running Joomla version 1.5.20 and Very Simple Gallery Version 1.6.2

Many thanks for you assistance
Mike

@Mike
Mittwoch, den 30. November 2011 um 22:10 Uhr
A. Berger

Hi Mike!

Open the article that contains the code for the gallery and switch to HTML-view. You will see, that the code is heavily fragmented by HTML-Tags (e.g. class="scayt-misspell").
Please remove these tags. They prevent the code from getting detected/executed by the plugin.

The origin of these tags seems btw. to be a bug in the used editor (CKEditor) that happens when using the spellchecker with InternetExplorer :)
Check this link for further information: dev.ckeditor.com/ticket/6114

Best regards
Andreas

Error message on gallery page
20 Dienstag, den 29. November 2011 um 00:18 Uhr
Lucy Coco

Hi

I love this plug in, it was much easier to install than others I tried, and it was also the only plug in gallery that actually worked for me.  However, I get the following error message on the page where the gallery is:
Warning: getimagesize() [function.getimagesize]: Filename cannot be empty in/home/*******/public_html/new/plugins/content/smartresizer/smartresizer.php on line 327
I have googled this put couldn't find any solution.  Can anyone help?

Thanks in advance

@Lucy Coco
Dienstag, den 29. November 2011 um 22:19 Uhr
A. Berger

Hi Lucy!

I confess, I have no idea why the plugin "SmartResizer" (check the Error Message) has problems used in combination with the Very Simple Image Gallery, but I would check the website/Support-forum of the developer of this plugin, maybe the problem has already been discussed there.

Best regards
Andreas

Thumbnail caching does not update changes
19 Montag, den 31. Oktober 2011 um 15:33 Uhr
Vken Go

Hi,

The problem I'm having is updating the thumbnail images : refreshing and reloading updated images. The galleries I have has over 100 images, so caching is vital, but if I update 1 image, the thumbnail does not change where as the image it links to does. Is there a way to flush the thumbnail cache so that it regenerates new ones. Or is there another way around it? Cheers.

@Vken Go
Mittwoch, den 02. November 2011 um 21:32 Uhr
A. Berger

Hi Vken Go!

The plugin automatically generates a new scaled image/thumbnail if a new image appears in the folder (new file name) , you change a relevant setting in the backend (width/height/quality/cropping) or if the respective scaled image/thumbnail is not present.
If you change images without changing name/dimension, you can force the creation of new scaled image/thumbnail by either changing one of the listed background settings or just by deleting the folders vsig_images, vsig_thumbs or their content.

Best regards
Andreas

Problem with multiple vsig instances on one page
18 Dienstag, den 25. Oktober 2011 um 15:02 Uhr
Hunter

I have one page with tabs. In each tab an article is shown. In each article a vsig is defined with a different image folder.

On first tab the photo and thumbs is shown. On the other tabs only the thumbs of that gallery is shown. But when clicking on the thumbs on any tabs the photo on first tab is changing with the photo of the corresponding thumb on the last tab.

Can vsig not handle this? Or how can I solve this?

@Hunter
Mittwoch, den 26. Oktober 2011 um 13:25 Uhr
A. Berger

Hi Hunter!

Please provide a link to the page and the name of the extension you are using for your tabbed content.

Best regards
Andreas

Links don't seem to be working properly
17 Freitag, den 14. Oktober 2011 um 14:12 Uhr
D. Yamaguishi

Hi, first of all, thanks for the great job!

I installed vsig in two different pages, but the links of the second one don't open the images. I used no parameters inside the code.

The site is www.dicuore.com.br and the gallery that doesn't open the links is the 'criação'.

Tks a lot!

@D. Yamaguishi
Mittwoch, den 26. Oktober 2011 um 14:56 Uhr
A. Berger

Hi D. Yamaguishi!

Please check if you have set a default blank link in this article. If so - please remove it.

Best regards
Andreas

Link Question
16 Dienstag, den 11. Oktober 2011 um 18:20 Uhr
Bunnar

First of all, thank you so much for this simple plugin!  It's the only gallery I've been able to get to work with my Joomla! site.  I do have a question, though... Is there any code to link each full sized image displayed within the gallery to a separate page?  Or do they all just link to the one default address that I specify in the code?

Thank you!

@Bunnar
Mittwoch, den 26. Oktober 2011 um 12:43 Uhr
A. Berger

Hi Bunnar!

Check the page "Howto Plugin Code", it explains the feature "Links".

The default link: {*vsig_l}gallery-number||URL|titel|target{/vsig_l*} - without the asterisks
The specif link: {*vsig_l}gallery-number|imagefile|URL|titel|target{/vsig_l*} - without the asterisks

You see, setting specific links for specific images just requires to set the image file name as second parameter, that's it.

Best regards
Andreas

Metadata file showing up as captions
15 Montag, den 20. Juni 2011 um 23:43 Uhr
Maggs

Hi, I'm having a problem with what seems to be the metadata (camera make) shows up as captions.

I Can't seem to turn it off.
It wasn't there before when it was on a test server (zoka.cc) but when we transfered it into its actual hosting and domain name it showed up. From what we know, the captions would only show up if you add a "label.txt" file within the folder of a specific gallery (which we did) for only one gallery needs to have a caption.
For the rest of the galleries, it shouldn't have a caption. But like I mentioned a "Olympus Digital Camera" captions displays on specific photos which the Olympus camera was used.

Any ideas?
Thanks!

http://img827.imageshack.us/img827/6756/01ll2.jpg

@Maggs
Sonntag, den 26. Juni 2011 um 16:33 Uhr
A. Berger

Hi Maggs!

I'm not sure about the extension you are using, but it doesn't seem to be one of mine.

Best regards
Andreas

very simple image gallery plugin
14 Montag, den 20. Juni 2011 um 03:59 Uhr
ariyagallery

dear andreas

I would like to thank you for this great image gallery that work simply for even a beginner like me,,,

I cross my finger for you,,,,,,

with respect

Plugin not working in SOBI
13 Dienstag, den 14. Juni 2011 um 05:59 Uhr
Zahidi

I use it in SOBI but it didnt work! here is the link
http://www.joyfulbrides.com/index.php?option=com_sobi2&sobi2Task=sobi2Details&catid=43&sobi2Id=371&Itemid=27
photo folder is oneworldhotel and i place it in images/stories/

help please!
thanks

@Zahidi
Dienstag, den 14. Juni 2011 um 21:24 Uhr
A. Berger

Hi Zahidi!

The "Very Simple Image Gallery" is a Joomla! content plugin. Please check the SOBI2 support forum if the component executes content plugins. Maybe this has to enabled separately. If the component does not execute content plugins at all, there is no way to use the plugin. In this case I would check the category "Extension specific" at extensions.joomla.org for extensions, explicitly developed for the usage within SOBI2.

Best regards
Andreas

Captions working on some galleries, others not.
12 Sonntag, den 12. Juni 2011 um 19:03 Uhr
Sarah

I've setup multiple articles within various categories, each with a gallery. The first category works fine. Gallery with caption on first image, perfect (Residential New: 72.34.48.154/~ruhfplit/index.php?option=com_content&view=category&layout=blog&id=49&Itemid=171).  But when I skip to another category (Residential Additions and Renovations: http://72.34.48.154/~ruhfplit/index.php?option=com_content&view=category&layout=blog&id=50&Itemid=208), the captions are not showing up.  I've tried everything from resizing images, checking all menu settings, module settings, article settings, etc. I compared the code on all articles, they match with the ones that are working... So I'm baffled. Am I missing something here?


Every first image of my galleries should have a caption, that is not happening. Please help.

@Sarah
Montag, den 13. Juni 2011 um 20:42 Uhr
A. Berger

Hi Sarah!

Hard to tell because the link require user/pass I don't have. In addition, please post the code you are using in the article(s).

Best regards
Andreas

Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135
Deutsch
Panoramic Image Viewer
Follow me on Facebook
Follow me on Google+

bretteleben.de

Add to circles

Wer ist online
Wir haben 57 Gäste online