Startseite Joomla Very Simple Image Gallery - FAQ & Troubleshooting
Hauptmenü
Meist gelesen
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79
Support

Wenn Sie die Erweiterungen und Scripts auf diesen Seiten nützlich finden, freue ich mich über Ihre Unterstützung. Danke!

Betrag: 

Neueste Beiträge
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109
Very Simple Image Gallery Plugin FAQ & Troubleshooting
Geschrieben von: Andreas Berger   
Sonntag, den 27. September 2009 um 17:48 Uhr

PROBLEM: Leere Seite beim Aufruf eines Artikels mit Galerie

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

PROBLEM: Weder Bilder noch Thumbnails werden angezeigt (leere Rahmen)

PROBLEM: Nur der Code {*vsig}ordner{/vsig*} wird angezeigt - Darstellung in Modul

 

 

PROBLEM: Leere Seite beim Aufruf eines Artikels mit Galerie

Führt der Aufruf einer Seite auf der eine Galerie eingebunden ist dazu, dass nur eine leere Seite angezeigt wird, dann ist der Grund dafür vermutlich ein "Fatal Error", ausgelöst durch die GD lib, eine Erweiterung von PHP. Um den Fehler beim Aufruf der Seite angezeigt zu bekommen reicht es, im Joomla! Backend unter "Site" > "Konfiguration" > "Server" im Abschnitt "Server" den Wert für den Parameter "Fehler berichten" auf "Maximum" zu setzen. (Anmerkung: Im aktivern Betrieb einer Webseite sollte das nach Behebung des Fehlers wieder zurückgesetzt werden!) Ruft man jetzt die Seite mit der Galerie auf, dann wird einem vermutlich ein "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)" angezeigt. Um dessen Behebung kümmert sich der nächste Punkt dieser FAQ.

 

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

Tritt beim Aufruf der Galerie diese Fehlermeldung auf (die angegebenes Bytes variieren), dann bedeutet das, dass die Erzeugung der Bilder/Thumbnails aus den Originalbildern mehr Arbeitsspeicher in Anspruch nimmt, als der Webserver einem PHP Script zur Verfügung stellt.
Man könnte nun entweder (in der lokalen Testumgebung) den Speichergrenzwert hochsetzen oder (am Webserver) den Webhoster darum ersuchen, den Account diesbezüglich besser auszustatten, doch in 99% der Fälle ist die Lösung einfach: Kleinere Bilder!

Das betrifft in erster Linie die Abmessungen (Breite/Höhe) der Bilder und nicht zwingend die Dateigröße. Die GD library von PHP benötigt zum Laden des Bildes in den Arbeitsspeicher (meines Wissens) rund 40 Bit pro pixel. Das bedeutet - zum Beispiel - die Erzeugung des skalierten Bildes bzw. des Thumbnails von einem Originalbild mit 800x600 Pixel benötigt zumindest 800x600x40bit = 2.23 MegaByte an Speicher.
Bei einem Bild 600x450 ergibt die Rechnung 600x450x40bit = 1.29 MegaByte, und so weiter.

Vielfach werden Bilder in Auflösungen hochgeladen, die für die Darstellung auf einer Webseite schlicht überdimensioniert sind. In einem üblichen Joomla! Template verbleiben für die Darstellung einer Galerie im Kontext des Inhalts vielleicht 600 bis allerhöchstens 800 Pixel an Breite. Bilder dieses Formats lassen sich - je nach Bild - bereits mit 50 bis 100 Kilobyte in ausgezeichneter Qualität darstellen. Lädt man Bilder direkt von der Digitalkamera hoch, dann haben diese aber Formate von bis zu 3000 Pixel Breite und sind teilweise bis zu 3 oder 4 Megabyte groß.
Die Nachteile großer (Dateigröße) Bilder liegen auf der Hand: Der Upload dauert wesentlich länger, man braucht mehr Platz am Server und man verschreckt seine Besucher, denn kaum jemand ist gewillt, auf das Laden eines Bildes von 3 MB oder mehr zu warten. Dazu kommt, dass das Skalieren der Bilder mit einem geeigneten Programm (z.B.: GIMP) wesentlich bessere Resultate bringt, als wenn man diese Aufgabe dem Browser überlässt.

Im Optimalfall skaliert man also die Bilder offline und lädt sie in einem Format hoch, das entweder exakt dem Format entspricht, in dem sie dann angezeigt werden (wenn mand das bereits ausprobiert hat) oder ein wenig größer (ein wenig größer deshalb, weil Browser beim hinaufskalieren noch schlechtere Ergebnisse bringen als beim Herunterskalieren).

Ach ja, die Fehlermeldung verschwindet dann übrigens auch.

 

PROBLEM: Weder Bilder noch Thumbnails werden angezeigt (leere Rahmen)

Werden an Stelle der Bilder und Thumbnails nur die Alternativtexte oder leere Rahmen angezeigt, dann überprüfen Sie bitte im Konfigurationspanel des Plugins den Status der GDlib.

Die GD Library, kurz GD oder GDlib, ist eine Programmbibliothek zur dynamischen Erzeugung und Manipulation von Grafiken und eine der verbreitesten Erweiterungen von PHP. Die Very Simple Image Gallery greift auf diese Erweiterung zu, um die skalierten Bilder und Vorschaubilder zu erzeugen.
Um über die Hinweise im Konfigurationspanel des Plugins hinaus zu überprüfen ob und wenn ja in welchem Umfang diese Erweiterung am Server zur Verfügung steht, ruft man im Joomla! Administrationsinterface den Menüpunkt Hilfe > Systeminfo >PHP-Information auf. Auf dieser Seite sucht man nach "gd". Im Optimalfall findet sich ein Abschnitt mit folgendem oder ähnlichem Inhalt:

gd

  • GD Support enabled
  • GD Version bundled (2.0.34 compatible)
  • FreeType Support enabled
  • FreeType Linkage with freetype
  • FreeType Version 2.1.9
  • T1Lib Support enabled
  • GIF Read Support enabled
  • GIF Create Support enabled
  • JPG Support enabled
  • PNG Support enabled
  • WBMP Support enabled
  • XBM Support enabled

Die erste Zeile zeigt an, dass die Erweiterung aktiviert ist, die zweite Zeile gibt Auskunft über die installierte Version. Danach folgen Angaben über zur Verfügung stehende Funktionalitäten und unterstützte Bildformate. Für die Very Simple Image Gallery sind die Formate GIF, JPG und PNG von Bedeutung.
Ist die GDlib nicht aktiviert oder werden diese Bildformate nicht unterstützt, dann sollte man das (in der lokalen Testumgebung) ändern oder (am Webserver) den Webhoster darauf hin ansprechen, ob eine Aktivierung möglich ist. Ohne diese Erweiterung ist die Very Simple Image Gallery nicht einsetzbar.

 

PROBLEM: Nur der Code {*vsig}ordner{/vsig*} wird angezeigt - Darstellung in Modul

Wird im Frontend keine Galerie sondern nur der Aufruf - {*vsig}ordner{/vsig*} (ohne Sterne) - angezeigt, dann überzeugt man sich zuerst, dass das Plugin auch aktiviert ist! Ist das der Fall, dann liegt das Problem in vielen Fällen darin, dass die Galerie nicht im Kontext des Hauptinhaltes angezeigt werden soll, sondern an einer Modulposition.
Nicht alle Erweiterungen, die anbieten eigenen Content an einer Modulposition anzuzeigen unterstützen die volle Funktionalität des Joomla! Frameworks und damit die Funktionen die das Plugin benötigt um fehlerlos zu arbeiten.
Von zumindest zwei Erweiterungen gibt es bislang aber Rückmeldungen von Nutzern, die bestätigen, dass diese Funktionalität bereitgestellt wird.

Eines ist das Modul "Module: Content with Plugins", gelistet bei extensions.joomla.org unter der Rubrik "News Display" > "Articles Embed".
Das Andere ist das Modul "Plugin in Module", gelistet bei extensions.joomla.org unter der Rubrik "Core Enhancements" > "Embed & Include".

Aber auch wenn das Plugin auf diese Art und Weise an einer Modulposition genutzt werden kann, ein Modul ist kein Artikel was dazu führt, dass dem Plugin - das die Identity des Artikels üblicherweise benutzt, um eindeutige Identifizierungen für JavaScript/CSS zu erzeugen - diese Unterscheidungsmöglichkeit fehlt. Solange es auf einer einzelnen Seite nur 1 Galerie gibt ist das kein Problem, aber wer vorhat, auf einer einzelnen Seite mehrere Galerien an Modulpositionen darzustellen, dem würde ich empfehlen auf eine Galerie ausweichen, die explizit als Modul entwickelt wurde.


Für Fragen und Anregungen steht die Kommentarfunktion zur Verfügung. Bitte geben Sie bei Ihrer Frage die verwendete Joomla! Version an und posten Sie bei Problemen - soweit möglich - einen Link zur betroffenen Seite.

Wer für sein Projekt zusätzliche Funktionen oder Adaptierungen über die Möglichkeiten des hier gebotenen Supports benötigt, der ist eingeladen, mich mit einer Beschreibung der gewünschten Leistungen und dem angedachten Budget per Email zu kontaktieren (Menüpunkt "Kontakt" im Topmenü).

Wer die Erweiterung nutzt den bitte ich, sie auf extensions.joomla.org zu bewerten und einen Erfahrungsbericht zu posten.

Zuletzt aktualisiert am Sonntag, den 20. März 2011 um 13:30 Uhr
 
Kommentare (31)
problem after change of my server
11 Mittwoch, den 08. Juni 2011 um 11:46 Uhr
justbeni

hey,

first i'd like to say that you've made a really nice plugin. thanx a lot.
but now i have a problem. i have used the plugin and everything works just fine, but after i have copied my homepage to another server, i got the following error:
Very Simple Image Gallery: Could not find folder /homepages/6/d219126038/htdocs/4rooms_concepts/images/aktuell/diplom_bg/

where can i change the location infront of /images/aktuell... ?

thx
greetings justbeni

@justbeni
Mittwoch, den 08. Juni 2011 um 20:36 Uhr
A. Berger

Hi justbeni!


Don't care about the path above your Joomla! root folder, in most cases it is fine. If the folder /images/aktuell/diplom_bg exists, check its directory permissions. They should be set to 755 (folder) and 644 (files).

Best regards
Andreas

images and captions
10 Mittwoch, den 01. Juni 2011 um 22:06 Uhr
KRughes

Using Joomla 1.6 with A Very Simple Gallery. It seems to work with images that were loaded before the extension was enabled but any new image I upload shows no image on the page and no thumbnail. Checked GB library and found  GD version: 2.0.34, JPG Support: enabled, PNG Support: enabled, GIF read Support: enabled, and GIF create Support: enabled.

I have attempted to create/rename folder, reload image but nothing seems to resolve. Any ideas?

@KRughes
Donnerstag, den 02. Juni 2011 um 20:29 Uhr
A. Berger

Hi KRughes!

Please check the set permissions of the images you uploaded. The files should be set to 644, the folder to 755.

Best regards
Andreas

Only the code {*vsig}verysimple{/vsig*} is shown
9 Mittwoch, den 01. Juni 2011 um 10:07 Uhr
Stanley

Dear all,


I have installed very simple image gallary in my website but failed to work.... i did insert the {*vsig}verysimple{/vsig*} for testing in new article.


but still show the code only in new article. Is there any problem for the code?


Remark:


1.Enabled the VSIG in plugin 
2.My joomla is 1.5 version
3. stories/verysimple/*.jpg < i did added a few jpg in this folder.


Please advise. Many thanks.

@Stanley
Donnerstag, den 02. Juni 2011 um 20:35 Uhr
A. Berger

Hi Stanley!

Please make sure

- to use the code without the asterisks, they are used here to prevent the code from getting executed
- to check the article from the frontend, the backend preview does not execute content plugins
- the article is displayed as main content, not within a module (if so, please check the page FAQ&Troubleshooting)
- the code is not fragmented with HTML-tags (open the article, switch to HTML-view to check this)
- the plugin is enabled

Best regards
Andreas

Menu disappears in IE after selecting a different thumb
8 Dienstag, den 31. Mai 2011 um 20:16 Uhr
Eric

Hi,

First of all, you've made a great plug-in!
There is one problem tough, I use SWmenuFree to create a propper drop-down menu, but my whole menu disappears after I select a new Thumb.
My problem can be seen on www.close-upfotografie.com. You would have to view the gallery with IE.
Hope you can help.

Kind regards
Eric

Menu Disappears in IE after selecting a different thumb
Freitag, den 03. Juni 2011 um 07:00 Uhr
Eric

Hi Andreas,

Thank you for trying, for now I will turn Javascript back off.

Keep up the good work!
Greetz Eric

@Eric
Donnerstag, den 02. Juni 2011 um 20:45 Uhr
A. Berger

Hi Eric!

Thanks for changing the settings. I saved the page locally and tried to find a solution but I have to confess - I failed. Whenever the JavaScript of the plugin changes the source of the main image - the menu disappears. One possible reason for this could be that the JavaScript of the menu (DropDownMenuX_Packed.js) uses the same Identity for an element of the menu than the plugin does for the main image. The problem - the source of this JavaScript is minified and this makes it difficult to work with.
Therefore - if you don't want to use the plugin with JavaScript disabled - I can only suggest to use another gallery extension. Sorry about that.

Best regards
Andreas

Menu disappears in IE after selecting a different thumb
Donnerstag, den 02. Juni 2011 um 14:14 Uhr
Eric

Hi Andears,

When you're right, you're right. I've switched on Javascript, so you can see my problem.

Greetz, Eric

@Eric
Dienstag, den 31. Mai 2011 um 21:38 Uhr
A. Berger

Hi Eric!

I'm sorry but as long as the option to use JavaScript is turned off in the configuration panel of the plugin (i.e. the problem cannot be seen), I have hardly a chance to track down the problem I cannot see. :)

Best regards
Andreas

I dont know...
7 Dienstag, den 31. Mai 2011 um 19:03 Uhr
Javier

Hi, I cant see the images, or de previews, when I dtrie to see qhere the image is, I get this message:

The requested URL /myfolder/subfolder/vsig_thumbs/pri2_89_50_80.jpg was not found on this server.
It looks like that folder doesnt exist. I'm using joomla 1.6

Thanks!!!

@Javier
Dienstag, den 31. Mai 2011 um 21:22 Uhr
A. Berger

Hi Javier!

What do you see at the page that should show the gallery at all? Is there an error message? Could you provide a link to the page?

Best regards
Andreas

any way to turn off auto-thumbnail generator?
6 Samstag, den 28. Mai 2011 um 23:42 Uhr
Vicky

Hi, this is great, but I prefer to make my own thumbnails. Is there any way to turn off the auto-generator? Also is there an easy way to do rollovers? I'm not very advanced. If VSIG can't do these things, can someone recommend a simple-to-use free or not-too-expensive plugin that does? (I also don't want lightbox). Thanks.

@Vicky
Montag, den 30. Mai 2011 um 20:25 Uhr
A. Berger

Hi Vicky!

I'm sorry, but this is not possible without patching the plugin. I suggest to have a look at the category "Photos & Images" at extensions.joomla.org, maybe one of the listed extension comes with the requested features out of the box.

Best regards
Andreas

Thumbs are shown different the full picture
5 Dienstag, den 17. Mai 2011 um 14:59 Uhr
Maarten

Hi,

If VSIG installed on www.mobilize-it.nl/uitvaarttruck (choose foto's) but the thumbs are different then the pictures.
This problem is only with Firefox.
For example: when you see thump no 2 and when you go over it with your mouse the there is another picture shown.

Can anyone help me?

@Maarten
Dienstag, den 17. Mai 2011 um 19:55 Uhr
A. Berger

Hi Maarten!

Switch back to an unpatched version of the plugin (i.e.: the plugin before your modifications), make sure that your template includes the JavaScript /plugins/content/plugin_vsig/vsig.js (check for a snippet that removes JavaScripts like mootools.js, caption.js and everything else that comes around from the Joomla! Head Data or disable/configure the extension you are using to control JavaScripts in the head of your site) and give it another try.
I predict - the problem will be gone :)

Best regards
Andreas

How to configure for IIS
4 Dienstag, den 17. Mai 2011 um 12:30 Uhr
Yeti

I have Joomla 1.6 installed on Server 2003 IIS for an intranet.  Unfortunately I cannot override the vsig plugin image location from using / which windows does not understand.
e.g. the file location is resolving as C:\Inetpub\intranetroot\J16/images/
This is because the module is picking up the site files location and adding /images/ to the end.  Windows will not recognize this location and as such the plugin fails at every turn.
Can the plugin php file be amended so that it will allow the module to use / instead of \ ????  Or perhaps to use the website address instead of a local file address.
I hope so as I have used this module on several production sites with no problems under linux and really appreciate it.

Any help would be greatly accepted!

@Yeti
Dienstag, den 17. Mai 2011 um 20:41 Uhr
A. Berger

Hi Yeti!

As far as I know from reports of users up till now IIS works fine with the plugin. In addition, I'm working locally on Windows using XAMPP and/or USBW. My error message (if I produce one) shows the same "split" path but the plugin works fine.

I suggest you get an error similar: Very Simple Image Gallery: Could not find folder C:\Inetpub\intranetroot\J16/images/
The problem/error is not caused by the fact that the path is reported with backslashes above and slashes below the web root. Please check if the folder with the images is write protected or if there is a typo in the path/folder name or if the code in your article is fragmented with HTML-tags (open the article and switch to HTML-view).
If the problem persists, please post the code you are using in your article, the setting of the parameter "Image root" and the complete error message.

Best regards
Andreas

css vsig
3 Mittwoch, den 04. Mai 2011 um 20:02 Uhr
Tycho

hi,

I have vsig installed and have the layout set to thumbnails align left and have 4 collums with 4 rows standing images show great, but now im trying to vertical* center the big image with the thumbnails. do i have to add a css class? im trying to set it up but wont get it to work. when i add a class it doesn't get it in the gallery.

hope you can help me out.
Thanks in advance

@Kaspers
Freitag, den 13. Mai 2011 um 21:19 Uhr
A. Berger

Hi Kaspers!

The caption for the initial main image is attached directly, all other captions are written into a JavaScript array and attached using JavaScript.
To achieve what you want there are two possible ways: 1.) patch the plugin, 2.) modify the stylesheet. As I already said, I don't have a working out-of-the-box solution because this option up till now wasn't on my roadmap.

Best regards
Andreas

question
Freitag, den 13. Mai 2011 um 12:09 Uhr
Kaspers

hey,

First of all i want to Thank you for your previous reply's.

i did figure it out myself as al the gallery's would be the same i hardcoded it in.

Can you help me out one more time? how does the caption get shown? how does it tell witch caption to pick.

because im working to get the captions below the gallery, now with a horizontal image it moves up to the image.. i want them to stay in one position.

No is the positioning not realy a problem but when i wright some DIV'S in that section he uses the same comment everywhere.
Could you tell me how the captions get handled?

@Tycho
Donnerstag, den 05. Mai 2011 um 20:08 Uhr
A. Berger

Hi Tycho!

I understand what you mean. I will think about a possiblity to vertically center the main image if the main image is set (either automatically or with an additional parameter but I cannot promise that this will become part of the plugin because it needs testing). At the moment there is no possibility to vertically center the main image because the plugin has no possibility to detect if the current image is a "high" one (i.e. no top margin) or a "wide" one (i.e. set top margin). The functionality is not available.

Best regards
Andreas

css visg
Donnerstag, den 05. Mai 2011 um 08:51 Uhr
Tycho

hi,

Thnks for the quick reply, well i did do that and because there were more images that are higher than wide i aligned it to that. But if i put a wide image in there it shows on top. so it would be the only option to make al images same size? Is it possible to add a style, i did found all the tags for the images and so on but if i put a new div with class in there nothing happens hope you can help.

Ps. It is a great gallery to start out with, realy nice and clean.

@Tycho
Mittwoch, den 04. Mai 2011 um 21:11 Uhr
A. Berger

Hi Tycho!

I confess, I have no idea if this can be done with CSS because I have never tried to do it.

It is the intention of the main image to start at the 'top' of the gallery and follow the dimensions set in the backend, taking into account that the thumbnails may need space left/right and taking into account the image proportions.
The thumbnails on the other hand are limited in width/height but not necessarily by number (sets are an optional feature) and therefore there is no correlation/connection between the limitless total height of the - aligned left/right - thumbs column(s) and the vertical position of the main image.
If I am tuning a gallery with thumbs left/right and sets, I do this by changing the number and size of the thumbs and the space between them till the result fits my needs.

Best regards
Andreas

Problem with caption alignment
2 Montag, den 18. April 2011 um 02:50 Uhr
Stephane

For some reason, the captions align left instead of under the image. As well, the image is centred no matter what I select as an "align the gallery" option in the plugin settings. (it is currently set to left) See: http://www.bareoaks.ca/index.php/about-naturism/history-of-naturism/sun-valley-gardens.html#2006-photos
I'm using Joomla 1.5.15 and vsig 1.6.5
But other than that problem, this plugin is brilliant!!

@Stephane
Dienstag, den 19. April 2011 um 20:57 Uhr
A. Berger

Hi Stephane!

The reason why the captions align left is that I told them to do so. If you want to center them, open the stylesheet /plugins/content/plugin_vsig/vsig.css and change "text-align:left !important;" to "text-align:center !important;" in the selector .vsig_top div.inside {} (for captions over the main image) or .vsig_top div.outside{} (below the main image) to center the captions.

The reason why the images align center is - exactly - that I told them to do so. :)
The parameter that allows to align the gallery - aligns the gallery within your content not the image within the available space. If you want to change this behavior, you will have to patch the plugin by modifying /plugins/content/vsig.php.

The reason why on your page the captions start left of the main image is that you have set the gallery to a width of 890 pixels whilst you limited the main images (using the parameter max. image height) to a width of 600 pixels. Either increase the image height or decrease the gallery width to allow the images to use the full gallery width - as the captions do - and the problem is solved.

Best regards
Andreas

Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135
Deutsch
Panoramic Image Viewer
Follow me on Facebook
Follow me on Google+

bretteleben.de

Add to circles

Wer ist online
Wir haben 215 Gäste online