Home Joomla Very Simple Image Gallery - FAQ & Troubleshooting
Main Menu
Most Read
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_mostread/helper.php on line 79
Support

If you like the products on these pages, your support is highly appreciated. Thank you very much!

Amount: 

Latest Items
Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109 Warning: Creating default object from empty value in /var/www/clients/client396/web1968/web/modules/mod_latestnews/helper.php on line 109
Very Simple Image Gallery Plugin FAQ & Troubleshooting
Written by Andreas Berger   
Sunday, 27 September 2009 17:48

PROBLEM: Empty page when trying to open a page with gallery

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

PROBLEM: Neither images nor thumbnails get shown (empty frames)

PROBLEM: Only the code {*vsig}folder{/vsig*} is shown - usage in module position

 

 

PROBLEM: Empty page when trying to open a page with gallery

If the call of a page with a gallery leads to an empty page, the reason probably is a "Fatal Error", caused by the GD lib, an extension to PHP. To display the error when opening the page, go to your Joomla! backend, navigate to "Site" > "Global Configuration" > "Server" and in the section "Server" increase the level of "Error Reporting" to "Maximum". (Note: In productive use this setting should be revised after fixing the problem!)
If you try to open the page with the gallery now, you will probably see a message such as "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)". The next item of this FAQ deals with this error.

 

ERROR: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3264 bytes)

If you get this error (amount of bytes will vary) when trying to open a page that contains a gallery, the amount of memory PHP needs to create the images/thumbnails exceeds the set maximum amount of memory a PHP script is allowed to use.
One possible solution would be to increase this amount (on your local test environment) or (on the web server) to ask your hoster if it is possible to enhance your account but - with a probability of 99% - the simple solution is: Smaller images!

This means in the first instance the image dimensions (width/height), not necessarily the image file size. The GD library of PHP needs to read in the image. This requires (as far as I know) about 40 Bit per pixel. This means - e.g. - that creating the image and thumbnail from an original with 800/600 needs at the least 800x600x40bit = 2.23 MegaByte.
For an image of 600/450 the calculation is 600x450x40bit = 1.29 MegaByte ... and so on.

In many cases images get uploaded far to large for web use. A common Joomla! template offers for a gallery in the context of the main content from 600 up to 800 pixel of width at the maximum. Images of this size can be displayed at excellent quality with - depending on the image - 50 up to 100 kilobyte. If you upload your images as they are saved from your digicam, they often come with dimensions up to 3000 or 4000 pixel of width and 3 or 4 megabyte of size.
The disadvantages of such large images are obviously: The upload takes a long time, you need a lot of space on your server and - important - scarcely any visitor is willing to wait for an image of 3 or 4 MB to load. Furthermore scaling an image offline with an appropriate program (e.g.: GIMP) gives you much better results than leaving it up to the visitors browser.

In the best case you scale your images offline to a format that exactly matches the size you are going to display them on your page (if you already fine tuned the gallery) or is a little above this size (above because browsers are still worse in up scaling images than they are in down scaling them).

By the way - doing so, the error disappears too.

 

PROBLEM: Neither images nor thumbnails get shown (empty frames)

If you get - instead of images and thumbnails - only the ALT-text or just empty frames, please open the configuration panel of the plugin and check the availability of the GD library.

The GD Library, short GD or GDlib, is a program library to dynamically create and manipulate graphics and one of the most widespread extensions of PHP. The Very Simple Image Gallery uses this extension to create the scaled images and thumbnails.
To get more information than the plugins configuration panel offers go to the Joomla! administration interface and open Help > System Info >PHP-Information. On this page search for "gd". In the best case you will find a chapter with the following or similar content:

gd

  • GD Support enabled
  • GD Version bundled (2.0.34 compatible)
  • FreeType Support enabled
  • FreeType Linkage with freetype
  • FreeType Version 2.1.9
  • T1Lib Support enabled
  • GIF Read Support enabled
  • GIF Create Support enabled
  • JPG Support enabled
  • PNG Support enabled
  • WBMP Support enabled
  • XBM Support enabled

The first line shows, that the extension is enabled, the second line holds the installed version. The followup lines hold information about available functionality and supported file types. For the Very Simple Image Gallery the file types GIF, JPG and PNG are of importance.
If the GDlib is not activated or these file formats are not supported, you should (on your local test environment) activate it or (on the web server) ask your hoster if it is possible to add this feature. Without the GDlib the Very Simple Image Gallery cannot be used.

 

PROBLEM: Only the code {*vsig}folder{/vsig*} is shown - usage in module position

If the frontend shows the code - {vsig}folder{/vsig*} (without asterisk) - instead of the gallery, the first thing to do is to check if the plugin is activated. If it is and the problem persists, in most cases you are trying to display the gallery on a module position instead of the context of the main content.
Not all extensions, that offer to display custom content on a module position, are supporting the whole functionality of the Joomla! framework and with it the functions the plugin needs to work properly.
Up till now two extensions are reported to offer the needed functionality:

One is the module "Module: Content with Plugins", listed at extensions.joomla.org under "News Display" > "Articles Embed".
The other is the module "Plugin in Module", listed at extensions.joomla.org under "Core Enhancements" > "Embed & Include".

Please be aware that - even if the plugin works this way - the fact that a module is not an article causes problems if you are going to use multiple instances of the plugin on one page because the plugin will not be able to write unique identifyers for JavaScript and CSS. If you need multiple instances on one page, I would indeed use a gallery, explititely developed as a module.


If you have questions or suggestions, please use the comment-function. Please include the installed Joomla! version and if you have problems - if any possible - the affected page in your comment.

If you need additional features or customizations for your project that exceed the scope of support offered through the comments, you are invited to submit your requirements specification and the planned budget by email (menu item "Contact" in the menu at the top).

If you use this extensions, please post a rating and a review at extensions.joomla.org.

Last Updated on Sunday, 20 March 2011 13:30
 
Comments (31)
problem after change of my server
11 Wednesday, 08 June 2011 11:46
justbeni

hey,

first i'd like to say that you've made a really nice plugin. thanx a lot.
but now i have a problem. i have used the plugin and everything works just fine, but after i have copied my homepage to another server, i got the following error:
Very Simple Image Gallery: Could not find folder /homepages/6/d219126038/htdocs/4rooms_concepts/images/aktuell/diplom_bg/

where can i change the location infront of /images/aktuell... ?

thx
greetings justbeni

@justbeni
Wednesday, 08 June 2011 20:36
A. Berger

Hi justbeni!


Don't care about the path above your Joomla! root folder, in most cases it is fine. If the folder /images/aktuell/diplom_bg exists, check its directory permissions. They should be set to 755 (folder) and 644 (files).

Best regards
Andreas

images and captions
10 Wednesday, 01 June 2011 22:06
KRughes

Using Joomla 1.6 with A Very Simple Gallery. It seems to work with images that were loaded before the extension was enabled but any new image I upload shows no image on the page and no thumbnail. Checked GB library and found  GD version: 2.0.34, JPG Support: enabled, PNG Support: enabled, GIF read Support: enabled, and GIF create Support: enabled.

I have attempted to create/rename folder, reload image but nothing seems to resolve. Any ideas?

@KRughes
Thursday, 02 June 2011 20:29
A. Berger

Hi KRughes!

Please check the set permissions of the images you uploaded. The files should be set to 644, the folder to 755.

Best regards
Andreas

Only the code {*vsig}verysimple{/vsig*} is shown
9 Wednesday, 01 June 2011 10:07
Stanley

Dear all,


I have installed very simple image gallary in my website but failed to work.... i did insert the {*vsig}verysimple{/vsig*} for testing in new article.


but still show the code only in new article. Is there any problem for the code?


Remark:


1.Enabled the VSIG in plugin 
2.My joomla is 1.5 version
3. stories/verysimple/*.jpg < i did added a few jpg in this folder.


Please advise. Many thanks.

@Stanley
Thursday, 02 June 2011 20:35
A. Berger

Hi Stanley!

Please make sure

- to use the code without the asterisks, they are used here to prevent the code from getting executed
- to check the article from the frontend, the backend preview does not execute content plugins
- the article is displayed as main content, not within a module (if so, please check the page FAQ&Troubleshooting)
- the code is not fragmented with HTML-tags (open the article, switch to HTML-view to check this)
- the plugin is enabled

Best regards
Andreas

Menu disappears in IE after selecting a different thumb
8 Tuesday, 31 May 2011 20:16
Eric

Hi,

First of all, you've made a great plug-in!
There is one problem tough, I use SWmenuFree to create a propper drop-down menu, but my whole menu disappears after I select a new Thumb.
My problem can be seen on www.close-upfotografie.com. You would have to view the gallery with IE.
Hope you can help.

Kind regards
Eric

Menu Disappears in IE after selecting a different thumb
Friday, 03 June 2011 07:00
Eric

Hi Andreas,

Thank you for trying, for now I will turn Javascript back off.

Keep up the good work!
Greetz Eric

@Eric
Thursday, 02 June 2011 20:45
A. Berger

Hi Eric!

Thanks for changing the settings. I saved the page locally and tried to find a solution but I have to confess - I failed. Whenever the JavaScript of the plugin changes the source of the main image - the menu disappears. One possible reason for this could be that the JavaScript of the menu (DropDownMenuX_Packed.js) uses the same Identity for an element of the menu than the plugin does for the main image. The problem - the source of this JavaScript is minified and this makes it difficult to work with.
Therefore - if you don't want to use the plugin with JavaScript disabled - I can only suggest to use another gallery extension. Sorry about that.

Best regards
Andreas

Menu disappears in IE after selecting a different thumb
Thursday, 02 June 2011 14:14
Eric

Hi Andears,

When you're right, you're right. I've switched on Javascript, so you can see my problem.

Greetz, Eric

@Eric
Tuesday, 31 May 2011 21:38
A. Berger

Hi Eric!

I'm sorry but as long as the option to use JavaScript is turned off in the configuration panel of the plugin (i.e. the problem cannot be seen), I have hardly a chance to track down the problem I cannot see. :)

Best regards
Andreas

I dont know...
7 Tuesday, 31 May 2011 19:03
Javier

Hi, I cant see the images, or de previews, when I dtrie to see qhere the image is, I get this message:

The requested URL /myfolder/subfolder/vsig_thumbs/pri2_89_50_80.jpg was not found on this server.
It looks like that folder doesnt exist. I'm using joomla 1.6

Thanks!!!

@Javier
Tuesday, 31 May 2011 21:22
A. Berger

Hi Javier!

What do you see at the page that should show the gallery at all? Is there an error message? Could you provide a link to the page?

Best regards
Andreas

any way to turn off auto-thumbnail generator?
6 Saturday, 28 May 2011 23:42
Vicky

Hi, this is great, but I prefer to make my own thumbnails. Is there any way to turn off the auto-generator? Also is there an easy way to do rollovers? I'm not very advanced. If VSIG can't do these things, can someone recommend a simple-to-use free or not-too-expensive plugin that does? (I also don't want lightbox). Thanks.

@Vicky
Monday, 30 May 2011 20:25
A. Berger

Hi Vicky!

I'm sorry, but this is not possible without patching the plugin. I suggest to have a look at the category "Photos & Images" at extensions.joomla.org, maybe one of the listed extension comes with the requested features out of the box.

Best regards
Andreas

Thumbs are shown different the full picture
5 Tuesday, 17 May 2011 14:59
Maarten

Hi,

If VSIG installed on www.mobilize-it.nl/uitvaarttruck (choose foto's) but the thumbs are different then the pictures.
This problem is only with Firefox.
For example: when you see thump no 2 and when you go over it with your mouse the there is another picture shown.

Can anyone help me?

@Maarten
Tuesday, 17 May 2011 19:55
A. Berger

Hi Maarten!

Switch back to an unpatched version of the plugin (i.e.: the plugin before your modifications), make sure that your template includes the JavaScript /plugins/content/plugin_vsig/vsig.js (check for a snippet that removes JavaScripts like mootools.js, caption.js and everything else that comes around from the Joomla! Head Data or disable/configure the extension you are using to control JavaScripts in the head of your site) and give it another try.
I predict - the problem will be gone :)

Best regards
Andreas

How to configure for IIS
4 Tuesday, 17 May 2011 12:30
Yeti

I have Joomla 1.6 installed on Server 2003 IIS for an intranet.  Unfortunately I cannot override the vsig plugin image location from using / which windows does not understand.
e.g. the file location is resolving as C:\Inetpub\intranetroot\J16/images/
This is because the module is picking up the site files location and adding /images/ to the end.  Windows will not recognize this location and as such the plugin fails at every turn.
Can the plugin php file be amended so that it will allow the module to use / instead of \ ????  Or perhaps to use the website address instead of a local file address.
I hope so as I have used this module on several production sites with no problems under linux and really appreciate it.

Any help would be greatly accepted!

@Yeti
Tuesday, 17 May 2011 20:41
A. Berger

Hi Yeti!

As far as I know from reports of users up till now IIS works fine with the plugin. In addition, I'm working locally on Windows using XAMPP and/or USBW. My error message (if I produce one) shows the same "split" path but the plugin works fine.

I suggest you get an error similar: Very Simple Image Gallery: Could not find folder C:\Inetpub\intranetroot\J16/images/
The problem/error is not caused by the fact that the path is reported with backslashes above and slashes below the web root. Please check if the folder with the images is write protected or if there is a typo in the path/folder name or if the code in your article is fragmented with HTML-tags (open the article and switch to HTML-view).
If the problem persists, please post the code you are using in your article, the setting of the parameter "Image root" and the complete error message.

Best regards
Andreas

css vsig
3 Wednesday, 04 May 2011 20:02
Tycho

hi,

I have vsig installed and have the layout set to thumbnails align left and have 4 collums with 4 rows standing images show great, but now im trying to vertical* center the big image with the thumbnails. do i have to add a css class? im trying to set it up but wont get it to work. when i add a class it doesn't get it in the gallery.

hope you can help me out.
Thanks in advance

@Kaspers
Friday, 13 May 2011 21:19
A. Berger

Hi Kaspers!

The caption for the initial main image is attached directly, all other captions are written into a JavaScript array and attached using JavaScript.
To achieve what you want there are two possible ways: 1.) patch the plugin, 2.) modify the stylesheet. As I already said, I don't have a working out-of-the-box solution because this option up till now wasn't on my roadmap.

Best regards
Andreas

question
Friday, 13 May 2011 12:09
Kaspers

hey,

First of all i want to Thank you for your previous reply's.

i did figure it out myself as al the gallery's would be the same i hardcoded it in.

Can you help me out one more time? how does the caption get shown? how does it tell witch caption to pick.

because im working to get the captions below the gallery, now with a horizontal image it moves up to the image.. i want them to stay in one position.

No is the positioning not realy a problem but when i wright some DIV'S in that section he uses the same comment everywhere.
Could you tell me how the captions get handled?

@Tycho
Thursday, 05 May 2011 20:08
A. Berger

Hi Tycho!

I understand what you mean. I will think about a possiblity to vertically center the main image if the main image is set (either automatically or with an additional parameter but I cannot promise that this will become part of the plugin because it needs testing). At the moment there is no possibility to vertically center the main image because the plugin has no possibility to detect if the current image is a "high" one (i.e. no top margin) or a "wide" one (i.e. set top margin). The functionality is not available.

Best regards
Andreas

css visg
Thursday, 05 May 2011 08:51
Tycho

hi,

Thnks for the quick reply, well i did do that and because there were more images that are higher than wide i aligned it to that. But if i put a wide image in there it shows on top. so it would be the only option to make al images same size? Is it possible to add a style, i did found all the tags for the images and so on but if i put a new div with class in there nothing happens hope you can help.

Ps. It is a great gallery to start out with, realy nice and clean.

@Tycho
Wednesday, 04 May 2011 21:11
A. Berger

Hi Tycho!

I confess, I have no idea if this can be done with CSS because I have never tried to do it.

It is the intention of the main image to start at the 'top' of the gallery and follow the dimensions set in the backend, taking into account that the thumbnails may need space left/right and taking into account the image proportions.
The thumbnails on the other hand are limited in width/height but not necessarily by number (sets are an optional feature) and therefore there is no correlation/connection between the limitless total height of the - aligned left/right - thumbs column(s) and the vertical position of the main image.
If I am tuning a gallery with thumbs left/right and sets, I do this by changing the number and size of the thumbs and the space between them till the result fits my needs.

Best regards
Andreas

Problem with caption alignment
2 Monday, 18 April 2011 02:50
Stephane

For some reason, the captions align left instead of under the image. As well, the image is centred no matter what I select as an "align the gallery" option in the plugin settings. (it is currently set to left) See: http://www.bareoaks.ca/index.php/about-naturism/history-of-naturism/sun-valley-gardens.html#2006-photos
I'm using Joomla 1.5.15 and vsig 1.6.5
But other than that problem, this plugin is brilliant!!

@Stephane
Tuesday, 19 April 2011 20:57
A. Berger

Hi Stephane!

The reason why the captions align left is that I told them to do so. If you want to center them, open the stylesheet /plugins/content/plugin_vsig/vsig.css and change "text-align:left !important;" to "text-align:center !important;" in the selector .vsig_top div.inside {} (for captions over the main image) or .vsig_top div.outside{} (below the main image) to center the captions.

The reason why the images align center is - exactly - that I told them to do so. :)
The parameter that allows to align the gallery - aligns the gallery within your content not the image within the available space. If you want to change this behavior, you will have to patch the plugin by modifying /plugins/content/vsig.php.

The reason why on your page the captions start left of the main image is that you have set the gallery to a width of 890 pixels whilst you limited the main images (using the parameter max. image height) to a width of 600 pixels. Either increase the image height or decrease the gallery width to allow the images to use the full gallery width - as the captions do - and the problem is solved.

Best regards
Andreas

Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 129 Warning: Illegal string offset 'active' in /var/www/clients/client396/web1968/web/templates/biz_blue_ii/html/pagination.php on line 135
English
Panoramic Image Viewer
Follow me on Facebook
Follow me on Google+

bretteleben.de

Add to circles

Who's Online
We have 88 guests online